随着WordPress 5.9 的发布,WordPress登录页面中出现了一个新的多语言选择器,允许用户切换到网站上已安装的任何语言。只要你的WordPress网站中安装了一种以上的语言,那么这个多语言选择器就会自动显示,对于多语言网站来说这或许是一个很棒的功能,遗憾的是,它仅仅是在登录页面有用。

WordPress5.9中移除登录页面的语言选择器插图
个人觉得,这个多语言选择器对于我们国内大多数使用者来说是不需要的,因为我们的网站后台都是自己在登录使用,并且面向的都是国内用户。对我这种强迫症患者来说,反而看起来更加难受。

如果你跟我一样,既不需要这个功能,又是个强迫症患者,不希望在登录页面出现这个新的语言选择器。可以通过WordPress 5.9 附带的一个过滤器来禁用多语言选择器,你只需要在当前使用WordPress主题的“functions.php”文件中添加以下代码即可:

add_filter( ‘login_display_language_dropdown’, ‘__return_false’ );

最后说个题外话,不管是WordPress程序还是主题又或者是插件,并非最新版本就是最好的,稳定比什么都重要,新版本初期往往都会有各种小问题,少数情况还会出现严重错误,比如主题和插件是否兼容WordPress最新版本。

昨天我就遇到了一个用户,说是更新WordPress 5.9之后编辑器坏了,显示未知错误,无法进入编辑界面。

我进入到后台看了一下,就是因为安装的某个插件不兼容WordPress 5.9 引起的,所以新版本发布的时候,最好不要第一时间就去更新,等个一星期,让主题和插件开发者去测试是否兼容,如果不兼容他们也会第一时间更新处理的。

? 最后,请大家放心,我们的WordPress主题兼容 WordPress 5.9。

发表回复

您的电子邮箱地址不会被公开。