最近有好几个项目要上线,因此需要在阿里云购买N个ECS,因为目前 Windows Server 的版本都到 Windows Server 2016 ,所以最起码也用 Windows Server 2012 的版本,然而在安装数据库MSSQL2012之前需要安装 .Net Framework 3.5 ,在“添加角色和功能向导中”安装.Net Framework 3.5就报错了,提示找不到源文件(如下图)。

阿里云ECS服务器windows server 2012安装.NET Fromework 3.5失败解决方法插图

提示的错误信息详情如下:

安装一个或多个角色、角色服务或功能失败。

找不到源文件。请在尝试在新的“添加角色和功能”向导会话中安装角色、角色服务或功能,然后在向导的“确认”页中单击“指定备用源路径”以指定安装所需的源文件的有效位置。目标服务器的计算机账户必须能够访问该位置。

【解决方法】

a.在开始菜单中打开PowerShell,鼠标右击选择“以管理员身份运行”,如果找不到可以在“运行”中输入“PowerShell”然后按回车键即可打开PowerShell。

b.按照顺序输入如下的脚本:在脚本执行的过程中,会出现安装进度,如遇到进度不动了,请耐性等待。

c.执行完成重启掉服务器

1. Set-ItemProperty -Path 'HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU' -Name UseWUServer -Value 0
2. Restart-Service -Name wuauserv
3. Install-WindowsFeature Net-Framework-Core
4. Set-ItemProperty -Path 'HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU' -Name UseWUServer -Value 1
5. Restart-Service -Name wuauserv

在重启服务器完成之后就可以发现已经可以ECS服务器安装.Net Framework 3.5了。此方法亲测有效!

其他:

阿里云官方对这个问题也有给出解决方案。

https://help.aliyun.com/knowledge_detail/40970.html

1、【运行】输入gpedit.msc打开组策略,依次选择【计算机配置】—【管理模板】—【windows 组件】—【windows 更新】

2、然后双击“指定 Intranet Microsoft 更新服务位置”,将设置选择为“未配置

3、执行 gpupdate命令更新组策略即可。

阿里云ECS服务器windows server 2012安装.NET Fromework 3.5失败解决方法插图1

经过本人亲测,这个解决方案不靠谱,因为默认就是未配置,所以各位先按照上面我提供方法去尝试,实在不行再看阿里云的这个解决方案吧。

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注